-
Notifications
You must be signed in to change notification settings - Fork 1
/
Copy pathStringTokens.java
86 lines (62 loc) · 2.18 KB
/
StringTokens.java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
/*
Given a string, s
, matching the regular expression [A-Za-z !,?._'@]+, split the string into tokens. We define a token to be one or more consecutive English alphabetic letters. Then, print the number of tokens, followed by each token on a new line.
Note: You may find the String.split method helpful in completing this challenge.
Input Format
A single string, s
.
Constraints
s is composed of any of the following: English alphabetic letters, blank spaces, exclamation points (!), commas (,), question marks (?), periods (.), underscores (_), apostrophes ('), and at symbols (@).
Output Format
On the first line, print an integer,
, denoting the number of tokens in string (they do not need to be unique). Next, print each of the tokens on a new line in the same order as they appear in input string
.
Sample Input
He is a very very good boy, isn't he?
Sample Output
10
He
is
a
very
very
good
boy
isn
t
he
Explanation
We consider a token to be a contiguous segment of alphabetic characters. There are a total of
such tokens in string , and each token is printed in the same order in which it appears in string .
*/
import java.io.*;
import java.util.*;
import java.lang.Object.*;
public class Solution {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
String s = scan.nextLine();
/*Write your code here.
Provide the regular expression and split the string with it
Find the length of total split string and print them
String regex ="A-Za-z !,?._'@";
System.out.pritnln(s.split(regex));
trim()is a built-in function that eliminates leading and trailing spaces
*/
if (s.trim().length()==0 || s.trim().length()>=400000){
System.out.println(0);
return;
}
String regex="[ !,?._'@]+";
String split_string[]=s.trim().split(regex);
System.out.println(split_string.length);
for(String w:split_string){
System.out.println(w);
/* int count=split_string.size();
System.out.println(count);
*/
}
// System.out.println(a);
scan.close();
}
}